const regex = /^CTR.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^CTR.*$', 'gm')
const str = `CTRasdkljfhalksjdfhalksjdfhalskjhf
2f3232rjfkalkj23f2a523gap289gaCTR
23rCTRCTRs;flkjs;ldfjkCTR
CTR23dfhalskjhf
CTRasdkljfhalksjd234251dfhalskjhf
CTRasdkljf3623462346jdfhalskjhf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}