import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\bjack\\b.*\\bjack\\b|.*\\bjames\\b.*\\bjames\\b)(?=.*\\bjack\\b.*\\bjames\\b).*$";
final String string = "hi jack here is james\n"
+ "hi james here is jack\n"
+ "hi james jack here is jack james\n"
+ "hi jack james here is james jack\n"
+ "hi jack jack here is jack james\n"
+ "hi james james here is james jack\n"
+ "hi jack jack jack here is james\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}