import re
regex = re.compile(r"^(?!.*\bjack\b.*\bjack\b|.*\bjames\b.*\bjames\b)(?=.*\bjack\b.*\bjames\b).*$", flags=re.MULTILINE)
test_str = ("hi jack here is james\n"
"hi james here is jack\n"
"hi james jack here is jack james\n"
"hi jack james here is james jack\n"
"hi jack jack here is jack james\n"
"hi james james here is james jack\n"
"hi jack jack jack here is james\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")