use strict;
my $str = 'Valid Values: 18.50, 5556.50 Invalid Values: 18.555, 5879.5877 etc
Those are all invalid: 123456789.12, .12.';
my $regex = qr/\b\d{1,8}\.(?=\d{1,2}\b)\d{2}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}