$re = '/\b\d{1,8}\.(?=\d{1,2}\b)\d{2}/';
$str = 'Valid Values: 18.50, 5556.50 Invalid Values: 18.555, 5879.5877 etc
Those are all invalid: 123456789.12, .12.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);