import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "visit(?=.{0,40}?(?:<\\/?a|\\.(?<=[a-z0-9]\\.)[a-z]))(?!(?:[^<]|<(?!\\/?code>))*+<\\/code>)";
final String string = "\n"
+ "visit abc.xyz\n\n"
+ "visit abc\n"
+ "abc.xyz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}