$re = '/visit(?=.{0,40}?(?:<\/?a|\.(?<=[a-z0-9]\.)[a-z]))(?!(?:[^<]|<(?!\/?code>))*+<\/code>)/mi';
$str = '
visit abc.xyz
visit abc
abc.xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);