using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\s*\(\s*[\'""]?+\/?+((?!http|vendor|website).+?)[\'""]?\s*\)";
string input = @"url(""images"")
url ( 'images')
url(vendor/)
url(website/)
url(http://)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}