$re = '/url\s*\(\s*[\'"]?+\/?+((?!http|vendor|website).+?)[\'"]?\s*\)/';
$str = 'url("images")
url ( \'images\')
url(vendor/)
url(website/)
url(http://)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);