$re = '/(?:^"|;")(""|[\w\W]*?)(?=";|"$)|(?:^(?!")|;(?!"))([^;]*?)(?=$|;)|(\r\n|\n)/m';
$str = '"123123123;123123;123;123;123";"12-34-123-3";"123";;;"3(12, 3); 3(12, 3)";""0.123"" (1.23aa)";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);