re = /(?:^"|;")(""|[\w\W]*?)(?=";|"$)|(?:^(?!")|;(?!"))([^;]*?)(?=$|;)|(\r\n|\n)/m
str = '"123123123;123123;123;123;123";"12-34-123-3";"123";;;"3(12, 3); 3(12, 3)";""0.123"" (1.23aa)";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end