#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "7(?:1(?:7(?:24|3[01]|4[79]|5[089]|6[258])|8(?:3[49]|40|54)|9(?:0[1239]|1[034]|37|49|5[16]|6[48]))|2087|55(?:0[13457]|59|6[179]|7[034]|99))%"
Local $sString = "71901%" & @CRLF & _
"71902%" & @CRLF & _
"71903%" & @CRLF & _
"71909%" & @CRLF & _
"71910%" & @CRLF & _
"71911%" & @CRLF & _
"71912%" & @CRLF & _
"71913%" & @CRLF & _
"71914%" & @CRLF & _
"71949%" & @CRLF & _
"71950%" & @CRLF & _
"71951%" & @CRLF & _
"71956%" & @CRLF & _
"71964%" & @CRLF & _
"71968%" & @CRLF & _
"72087%" & @CRLF & _
"71834%" & @CRLF & _
"71937%" & @CRLF & _
"71839%" & @CRLF & _
"71840%" & @CRLF & _
"71854%" & @CRLF & _
"71724%" & @CRLF & _
"71730%" & @CRLF & _
"71731%" & @CRLF & _
"71747%" & @CRLF & _
"71749%" & @CRLF & _
"71750%" & @CRLF & _
"71758%" & @CRLF & _
"71759%" & @CRLF & _
"71762%" & @CRLF & _
"71765%" & @CRLF & _
"71768%" & @CRLF & _
"75501%" & @CRLF & _
"75503%" & @CRLF & _
"75504%" & @CRLF & _
"75505%" & @CRLF & _
"75507%" & @CRLF & _
"75559%" & @CRLF & _
"75561%" & @CRLF & _
"75567%" & @CRLF & _
"75569%" & @CRLF & _
"75570%" & @CRLF & _
"75573%" & @CRLF & _
"75574%" & @CRLF & _
"75599%" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")