# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"7(?:1(?:7(?:24|3[01]|4[79]|5[089]|6[258])|8(?:3[49]|40|54)|9(?:0[1239]|1[034]|37|49|5[16]|6[48]))|2087|55(?:0[13457]|59|6[179]|7[034]|99))%"
test_str = ("71901%\n"
"71902%\n"
"71903%\n"
"71909%\n"
"71910%\n"
"71911%\n"
"71912%\n"
"71913%\n"
"71914%\n"
"71949%\n"
"71950%\n"
"71951%\n"
"71956%\n"
"71964%\n"
"71968%\n"
"72087%\n"
"71834%\n"
"71937%\n"
"71839%\n"
"71840%\n"
"71854%\n"
"71724%\n"
"71730%\n"
"71731%\n"
"71747%\n"
"71749%\n"
"71750%\n"
"71758%\n"
"71759%\n"
"71762%\n"
"71765%\n"
"71768%\n"
"75501%\n"
"75503%\n"
"75504%\n"
"75505%\n"
"75507%\n"
"75559%\n"
"75561%\n"
"75567%\n"
"75569%\n"
"75570%\n"
"75573%\n"
"75574%\n"
"75599%\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.