$re = '/\s*\([^()]*\)\s*$/m';
$str = 'aaaaaa
bbbbbb (exclude)
cccccc';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;