re = /\s*\([^()]*\)\s*$/m
str = 'aaaaaa
bbbbbb (exclude)
cccccc'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result