use strict;
my $str = 'BBB|CCC|DDD=AAA
FFF|GGG|HHH|III|JJJ|KKK=EEE';
my $regex = qr/(\w+)\|(?=(?:\w+\|)*\w+=(\w+))/mp;
my $subst = '$1=$2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";