import re
regex = re.compile(r"(\w+)\|(?=(?:\w+\|)*\w+=(\w+))", flags=re.MULTILINE)
test_str = ("BBB|CCC|DDD=AAA\n"
"FFF|GGG|HHH|III|JJJ|KKK=EEE")
subst = "$1=$2\\n"
result = regex.sub(subst, test_str)
if result:
print(result)