import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "M(\\d)(?!\\1{2})\\d{2}";
final String string = "M000\n"
+ "M001\n"
+ "M119\n"
+ "M002\n"
+ "Mast\n"
+ "M555\n"
+ "M222\n"
+ "M333\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}