import re
regex = re.compile(r"M(\d)(?!\1{2})\d{2}")
test_str = ("M000\n"
"M001\n"
"M119\n"
"M002\n"
"Mast\n"
"M555\n"
"M222\n"
"M333\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")