package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/(.+?\/){3}(.*?)\/`)
var str = `https://www.transfermarkt.de/sv-werder-bremen/startseite/verein/86`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}