$re = '/https?:\/\/(.+?\/){3}(.*?)\//m';
$str = 'https://www.transfermarkt.de/sv-werder-bremen/startseite/verein/86';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);