import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\shostname=(?:[^\\s.]+\\.)*?(?P<myfield>[^\\s.]+\\.(?:(?:ac|co)\\.uk|govt?\\.uk|judiciary\\.uk|l(?:ea|td)\\.uk|m(?:e|il|od)\\.uk|n(?:et|hs|ic)\\.uk|orgn?\\.uk|p(?:arliament|lc|olice)\\.uk|(?:royal|sch)\\.uk|[^\\s.]+)(?!\\S))";
final String string = "hostname=www.aaa.bbb.someurl.net\n\n"
+ "hostname=www.amazon.co.uk\n\n"
+ "2021-07-20 18:19:14 reason=Not allowed to browse this category event_id=12345 protocol=HTTP action=Blocked transactionsize=16051 responsesize=789 requestsize=456 urlcategory=Blocked serverip=1.2.4.5 clienttranstime=0 requestmethod=GET refererURL=None useragent=Microsoft-Delivery location=Internal ClientIP=5.6.7.8 status=403 user=John url=dl.delivery.mp.microsoft.com/filestreamingservice/files/abcd-efgh-ijkl/pieceshash vendor=Zscaler hostname=dl.delivery.mp.microsoft.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}