const regex = /^.*\shostname=(?:[^\s.]+\.)*?(?P<myfield>[^\s.]+\.(?:(?:ac|co)\.uk|govt?\.uk|judiciary\.uk|l(?:ea|td)\.uk|m(?:e|il|od)\.uk|n(?:et|hs|ic)\.uk|orgn?\.uk|p(?:arliament|lc|olice)\.uk|(?:royal|sch)\.uk|[^\s.]+)(?!\S))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\shostname=(?:[^\\s.]+\\.)*?(?P<myfield>[^\\s.]+\\.(?:(?:ac|co)\\.uk|govt?\\.uk|judiciary\\.uk|l(?:ea|td)\\.uk|m(?:e|il|od)\\.uk|n(?:et|hs|ic)\\.uk|orgn?\\.uk|p(?:arliament|lc|olice)\\.uk|(?:royal|sch)\\.uk|[^\\s.]+)(?!\\S))', 'gm')
const str = `hostname=www.aaa.bbb.someurl.net
hostname=www.amazon.co.uk
2021-07-20 18:19:14 reason=Not allowed to browse this category event_id=12345 protocol=HTTP action=Blocked transactionsize=16051 responsesize=789 requestsize=456 urlcategory=Blocked serverip=1.2.4.5 clienttranstime=0 requestmethod=GET refererURL=None useragent=Microsoft-Delivery location=Internal ClientIP=5.6.7.8 status=403 user=John url=dl.delivery.mp.microsoft.com/filestreamingservice/files/abcd-efgh-ijkl/pieceshash vendor=Zscaler hostname=dl.delivery.mp.microsoft.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}