using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zäöüÄÖÜß\s\d.,-]+?)\s*([\d\s]+(?:\s?[-|+\/]\s?\d+)?\s*[a-z]?)?\s*(?:\d{5})?\s*(.+)?$";
string input = @"Gewerbegebiet Ziesegrund 17440 Hohendorf bei Wolgast
Sonnenwiechser Str. 42 1/2 83052 Bruckmühl, Mangfall
Am Hamberg 4/1 79400 Kandern
Brüggerfeld 14 + 20 29574 Ebstorf
Straße des 17. Juni 18+19 88485 Berlin
Hochstr. 19 88045 Friedrichshafen
Straße des 17. Juni 23-25 a 12345 Berlin-Mitte
Domerschulstrasse 234 34070 Verlin
ERDINGERSTR.32 84405 DORFEN
GRüNERSTR. 14 A 67061 LUDWIGSHAFEN
KÖNIGSWINTER STR. 120 53227 BONN
GRÜNER WEG 11A
ERDINGERSTR.32 2443 DORFEN
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}