$re = '/^([a-zäöüÄÖÜß\s\d.,-]+?)\s*([\d\s]+(?:\s?[-|+\/]\s?\d+)?\s*[a-z]?)?\s*(?:\d{5})?\s*(.+)?$/mi';
$str = 'Gewerbegebiet Ziesegrund 17440 Hohendorf bei Wolgast
Sonnenwiechser Str. 42 1/2 83052 Bruckmühl, Mangfall
Am Hamberg 4/1 79400 Kandern
Brüggerfeld 14 + 20 29574 Ebstorf
Straße des 17. Juni 18+19 88485 Berlin
Hochstr. 19 88045 Friedrichshafen
Straße des 17. Juni 23-25 a 12345 Berlin-Mitte
Domerschulstrasse 234 34070 Verlin
ERDINGERSTR.32 84405 DORFEN
GRüNERSTR. 14 A 67061 LUDWIGSHAFEN
KÖNIGSWINTER STR. 120 53227 BONN
GRÜNER WEG 11A
ERDINGERSTR.32 2443 DORFEN
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);