using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]+):.*?(;|$)";
string substitution = @"$1$2";
string input = @"X: product 1;Y: product 2;Z: product 3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}