$re = '/([A-Z]+):.*?(;|$)/m';
$str = 'X: product 1;Y: product 2;Z: product 3';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;