package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?|\[(.*?)\]\{(.*?)\}|\[(.*?)\](.*?))`)
var str = `[a-z]{1}[-][0-9]{4}[-][ab]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}