$re = '/(?|\[(.*?)\]\{(.*?)\}|\[(.*?)\](.*?))/';
$str = '[a-z]{1}[-][0-9]{4}[-][ab]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);