using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"center=(-?\d+\.\d+)%2C(-?\d+\.\d+)";
string input = @"https://maps.googleapis.com/maps/api/staticmap?scale=1¢er=40.744221%2C73.982854&language=en&zoom=15&markers=scale%3A1%7Cicon%3Ahttps%3A%2F%2Fyelp-images.s3.amazonaws.com%2Fassets%2Fmap-markers%2Fannotation_32x43.png%7C40.744221%2C-73.982854&client=gme-yelp&sensor=false&size=315x150&signature=OjixVjNCwF7yLR5tsYw2fDRZ7bw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}