re = /center=(-?\d+\.\d+)%2C(-?\d+\.\d+)/m
str = 'https://maps.googleapis.com/maps/api/staticmap?scale=1¢er=40.744221%2C73.982854&language=en&zoom=15&markers=scale%3A1%7Cicon%3Ahttps%3A%2F%2Fyelp-images.s3.amazonaws.com%2Fassets%2Fmap-markers%2Fannotation_32x43.png%7C40.744221%2C-73.982854&client=gme-yelp&sensor=false&size=315x150&signature=OjixVjNCwF7yLR5tsYw2fDRZ7bw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end