import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<block>[\\s|\\t]Name[\\s|\\t]+data3[\\s|\\t]+.*?<\\/block>";
final String string = "<block>\n"
+ "Name data1\n"
+ "Spec 36\n"
+ "</block>\n"
+ "<block>\n"
+ "Name data2\n"
+ "Spec 22\n"
+ "</block>\n"
+ "<block>\n"
+ "Name data3\n"
+ "Spec 56\n"
+ "</block>\n"
+ "<block>\n"
+ "Name data4\n"
+ "Spec 41\n"
+ "</block>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}