re = /<block>[\s|\t]Name[\s|\t]+data3[\s|\t]+.*?<\/block>/m
str = '<block>
Name data1
Spec 36
</block>
<block>
Name data2
Spec 22
</block>
<block>
Name data3
Spec 56
</block>
<block>
Name data4
Spec 41
</block>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end