$re = '/\((?<Classification>[U|S])\)(?<Content>[^\(*)]*)/m';
$str = '(U) foo bar
some more text
(S) yep here too';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);