package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s*(\d+)x(\w+)\s*)+`)
var str = `1xAAAA,2xBBBB,3xDDDD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}