$re = '/(?:\s*(\d+)x(\w+)\s*)+/m';
$str = '1xAAAA,2xBBBB,3xDDDD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);