re = /^\s*(?<mac>\w{4}\.\w{4}\.\w{4})\s*(?<vlan>\d*)\s*(?<type>\w*)\s*(?<port>(\w|-|\/|:|\d*)*)\s*(?<vc>\w*\s*\d*)\s*(?<time>(\w|-|\/|:|\d*)*)$/m
str = ' ac9e.1797.b9f3 1007 Dynamic gpon-onu_1/2/7:1 vport 1 N/A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end