import Foundation
let pattern = #"^\s*(?<mac>\w{4}\.\w{4}\.\w{4})\s*(?<vlan>\d*)\s*(?<type>\w*)\s*(?<port>(\w|-|\/|:|\d*)*)\s*(?<vc>\w*\s*\d*)\s*(?<time>(\w|-|\/|:|\d*)*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" ac9e.1797.b9f3 1007 Dynamic gpon-onu_1/2/7:1 vport 1 N/A"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)