#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\b202[0-9]\.(?:1[0-2]|0[1-9])\.(?:3[01]|[12][0-9]|0[1-9]) Week (?:5[0-3]|[1-4][0-9]|0?[1-9]) Forecast\.xlsm$"
Local $sString = "/Users/X/Desktop/Test_Directory/2020.08.03 Week 53 Forecast.xlsm" & @CRLF & _
"/Users/X/Desktop/Test_Directory/2020.01.06 Week 2 Forecast.xlsm" & @CRLF & _
"/Users/X/Desktop/Test_Directory/2020.06.18 Week 25 Forecast.xlsm" & @CRLF & _
"/Users/X/Desktop/Test_Directory/2020.06.22 Week 26 Forecast.xlsm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")