# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*\b202[0-9]\.(?:1[0-2]|0[1-9])\.(?:3[01]|[12][0-9]|0[1-9]) Week (?:5[0-3]|[1-4][0-9]|0?[1-9]) Forecast\.xlsm$"
test_str = ("/Users/X/Desktop/Test_Directory/2020.08.03 Week 53 Forecast.xlsm\n"
"/Users/X/Desktop/Test_Directory/2020.01.06 Week 2 Forecast.xlsm\n"
"/Users/X/Desktop/Test_Directory/2020.06.18 Week 25 Forecast.xlsm\n"
"/Users/X/Desktop/Test_Directory/2020.06.22 Week 26 Forecast.xlsm")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.