# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\r?\n\r?\n(.*(?:\r?\n(?!\r?\n).*)*)\r?\n\r?\n"
test_str = ("\n\n"
"The following table provides the details of intangible assets\n"
"acquired, by major class and weighted average useful life:\n\n"
" \n\n"
"(USS in millions) USEFUL LIFE\n"
"Customer relationships 15 years $265\n"
"Intellectual property 10 years 120\n"
"Trade names 15 years 51\n"
"Favorable leases 38 years 26\n"
"Other various 2\n"
"Total intangible assets $464\n\n"
"The fair value in the opening balance sheet of the 30%\n"
"redeemable noncontrolling interest in Loders was estimated to\n"
"be $450 million.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.