package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d{1,2}:\d{2}):\d{2}\b`)
var str = `Thu Dec 31 22:00:00 UYST 2009`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}