$re = '/\b(\d{1,2}:\d{2}):\d{2}\b/m';
$str = 'Thu Dec 31 22:00:00 UYST 2009';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);