const regex = /^(?'line'public (?'type'\w+\??) (?'property'[A-z]+).*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'line\'public (?\'type\'\\w+\\??) (?\'property\'[A-z]+).*)$', 'gm')
const str = `public string? PropertyA { get; set; }
public string? PropertyB { get; set; }
public int? PropertyC { get; set; }`;
const subst = `/// <summary>\n/// $property\n/// <\/summary>\n$line\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);