# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Rechnungsdatum)([\s]*)(\d{1,2}\.\d{1,2}\.\d{1,4}|\d{1,2}\.\d{1,2})"
test_str = (" 1&1 Internet AG\n"
" Elgendorfer Str. 57\n"
" 56410 Montabaur\n\n"
"Rechnung Rechnungsdatum 16.02.2012\n"
" Rechnungsnummer 10000033321\n"
" Vertragsnummer\n"
" Kundennummer V4608229\n"
" K6990000\n\n"
"Musterfirma GmbH Bei Fragen: www.1und1.de/kontakt\n"
"Herr Willi Mustermann Ihr Kundenbereich (mit Hilfe zur Anmeldung)\n"
"Musterstraße 1 http://login.1und1.de\n"
"12345 Musterhausen\n"
" Aus Deutschland:\n"
" Telefon: 0721 96 00\n"
" (kostenfrei aus dem 1&1 Fest- und\n"
" 1&1 Mobilfunknetz)\n\n"
" Aus Österreich:\n"
" Telefon: (+43) 1 311 92 22 (Kosten abhängig von\n"
" Ihrem Festnetz-/Mobilfunkanbieter)\n\n"
" Servicezeiten: täglich rund um die Uhr\n\n"
"Ihre Rechnung (1&1 Website 5.0)\n\n"
"Abrechnungszeitpunkt: 15.02.2012\n\n"
"Pos. Die Leistungen im Überblick Tarif Einheiten Brutto (EUR) MwSt\n"
"Basispreis\n\n"
"1 Grundgebühr 4,99 EUR je Monat 6 Mon. 29,94 19%\n\n"
"15.02.2012-15.08.2012 droegemueller-luebeck.de\n\n"
"Zwischensumme (Netto) 25,16 EUR\n"
"+ Mehrwertsteuer (19,00%) 4,78 EUR\n\n"
"Zu zahlender Betrag 29,94 EUR\n\n"
"Der Rechnungsbetrag wird wie vereinbart von Ihrem Konto Nr. 881XXXX, BLZ 23070700 abgebucht. Die letzten Ziffern der Kontonummer haben wir aus\n"
"Sicherheitsgründen unkenntlich gemacht.\n\n"
"Bei Fragen zu Ihrer Rechnung bieten wir Ihnen in Ihrem 1&1 Control-Center die Möglichkeit, eine E-Mail Anfrage an unsere Rechnungsabteilung zu richten.\n"
"Das Kontaktformular finden Sie unter www.1und1.de/kontakt\n\n"
"Vorstand: Henning Ahlert, Ralph Dommermuth, Matthias Ehrlich, Robert Hoffmann, Markus Huhn, Hans-Henning Kettler, Dr. Oliver Mauss, Jan Oetjen\n"
"Aufsichtsratsvorsitzender: Michael Scheeren · HRB Montabaur 6484 · USt-IdNr.: DE811247114\n\n"
"WestLB, BLZ 300 500 00, Konto 7904 865, IBAN DE61300500000007904865, SWIFT WELA DE DD\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.