import Foundation
let pattern = #"(?<=Rechnungsdatum)([\s]*)(\d{1,2}\.\d{1,2}\.\d{1,4}|\d{1,2}\.\d{1,2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1&1 Internet AG
Elgendorfer Str. 57
56410 Montabaur
Rechnung Rechnungsdatum 16.02.2012
Rechnungsnummer 10000033321
Vertragsnummer
Kundennummer V4608229
K6990000
Musterfirma GmbH Bei Fragen: www.1und1.de/kontakt
Herr Willi Mustermann Ihr Kundenbereich (mit Hilfe zur Anmeldung)
Musterstraße 1 http://login.1und1.de
12345 Musterhausen
Aus Deutschland:
Telefon: 0721 96 00
(kostenfrei aus dem 1&1 Fest- und
1&1 Mobilfunknetz)
Aus Österreich:
Telefon: (+43) 1 311 92 22 (Kosten abhängig von
Ihrem Festnetz-/Mobilfunkanbieter)
Servicezeiten: täglich rund um die Uhr
Ihre Rechnung (1&1 Website 5.0)
Abrechnungszeitpunkt: 15.02.2012
Pos. Die Leistungen im Überblick Tarif Einheiten Brutto (EUR) MwSt
Basispreis
1 Grundgebühr 4,99 EUR je Monat 6 Mon. 29,94 19%
15.02.2012-15.08.2012 droegemueller-luebeck.de
Zwischensumme (Netto) 25,16 EUR
+ Mehrwertsteuer (19,00%) 4,78 EUR
Zu zahlender Betrag 29,94 EUR
Der Rechnungsbetrag wird wie vereinbart von Ihrem Konto Nr. 881XXXX, BLZ 23070700 abgebucht. Die letzten Ziffern der Kontonummer haben wir aus
Sicherheitsgründen unkenntlich gemacht.
Bei Fragen zu Ihrer Rechnung bieten wir Ihnen in Ihrem 1&1 Control-Center die Möglichkeit, eine E-Mail Anfrage an unsere Rechnungsabteilung zu richten.
Das Kontaktformular finden Sie unter www.1und1.de/kontakt
Vorstand: Henning Ahlert, Ralph Dommermuth, Matthias Ehrlich, Robert Hoffmann, Markus Huhn, Hans-Henning Kettler, Dr. Oliver Mauss, Jan Oetjen
Aufsichtsratsvorsitzender: Michael Scheeren · HRB Montabaur 6484 · USt-IdNr.: DE811247114
WestLB, BLZ 300 500 00, Konto 7904 865, IBAN DE61300500000007904865, SWIFT WELA DE DD
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)