$re = '/(?<=Location # \d{5} )(\d*)\s(.*)/';
$str = 'Location # 06296 1829 GOLIAD RD.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);