re = /(?<=Location # \d{5} )(\d*)\s(.*)/
str = 'Location # 06296 1829 GOLIAD RD.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end