import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z0-9]+\\.[a-z]{2,}";
final String string = "honor.watch magic 2 46mm туалетная вода.men 212.vip amd radeon r5.tm.graphics дренажная помпа.si 2100 sauermann смарт часы айфон.watch 6 surf.coffee меню москва semenasad.ru каталог с фото замена стекла на.apple.watch\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}