$re = '/[a-z0-9]+\.[a-z]{2,}/m';
$str = 'honor.watch magic 2 46mm туалетная вода.men 212.vip amd radeon r5.tm.graphics дренажная помпа.si 2100 sauermann смарт часы айфон.watch 6 surf.coffee меню москва semenasad.ru ка талог с фото замена стекла на.apple.watch
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);